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The information described in this document is the exclusive intellectual property of 
 Nuvoton Technology Corporation and shall not be reproduced without permission from Nuvoton. 

 

Nuvoton is providing this document only for reference purposes of NuMicro microcontroller based system 
design. Nuvoton assumes no responsibility for errors or omissions. 

All data and specifications are subject to change without notice. 

 

For additional information or questions, please contact: Nuvoton Technology Corporation.  
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1 OVERVIEW 

This document describes the firmware development environment used to build an application in 
the NuMaker-M2354 board and how to use board supporting package (BSP) including necessary 
drivers to develop applications with M2354. The guidelines on how to build the sample code of 
BSP are also included. 

 

2 BOARD SUPPORTING PACKAGE (BSP) 

The BSP contains M2354 driver, library and sample code. The driver is based on CMSIS. The 
libraries are smart card library and USB host library. All peripheral sample codes are provided to 
help user to understand how they work and how to use them. Furthermore, the TrustZone sample 
code is also included in the BSP. The detailed information of the BSP materials can be found in a 
readme file in the BSP root directory. 

 

Figure 2-1 M2354 BSP Folder Structure 
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3 INSTALLING TOOL DRIVERS 

The NuMaker-M2354 board has built in with Nuvoton Nu-Link ICE on board. By default KEIL, IAR and 
GCC project settings, the Nu-Link ICE is used to download and debug the sample code. In order to let 
Nu-Link ICE works with the IDE, user needs to install the Nu-Link KEIL/IAR or OpenOCD driver and 
connected to the Nu-Link ICE via the USB cable. 

In addition, if user wants to M2354 back to factory default state, ICP Programming Tool should be 
installed and connected with Nu-Link ICE via USB cable. 

Since the M2354 architecture is based on Arm
®
-v8M with TrustZone

®
 inside. It is recommended to use 

KEIL MDK Plus/Pro V5.28 or IAR EWARM V8.32.1 or GNU Nuvoton Eclipse V1.01.017 and later 
version. 

Moreover, Nuvoton has provided free-to-use IDE environment which is called Free Keil MDK Nuvoton 
Edition for M0/M23. It is free development IDE tool for all M0/M23 based MCU of Nuvoton. Users can 
use the Product Serial Number (PSN) “RUUCW-Q9G7H-ZK65W” to activate MDK for Nuvoton Cortex-
M0/M23 family. To install and activate Free Keil MDK Nuvoton Edition for M0/M23, please follow the 
steps as below:  

 Link to http://www2.keil.com/nuvoton/M0-M23. 
User can download Free Keil MDK Nuvoton Edition for M0/M23 by clicking “Download MDK 
Core”. 

 

Figure 3-1 Download Free Keil MDK Nuvoton Edition for M0/M23 
 
 
 
 
 
 
 
 
 
 
 

http://www2.keil.com/nuvoton/M0-M23
http://www2.keil.com/nuvoton/M0-M23
http://www2.keil.com/nuvoton/M0-M23
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 After installing Free Keil MDK Nuvoton Edition for M0/M23 done, open Keil
 
MDK and select 

“FileLicense Management…” to enter license management. 

 

Figure 3-2 Open Keil MDK and Enter License Management 

 

 Select “Single-User License” tab, and click “Get LIC via Internet”.  

 

Figure 3-3 Get LIC via Internet 
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 Fill in personal information. PSN should be “RUUCW-Q9G7H-ZK65W”.  

 

Figure 3-4 Fill in Personal Information 

 Click “Submit” button. 

 

Figure 3-5 Submit Personal Information 

 Get License ID Code from user’s email. 

 

Figure 3-6 Get License ID Code 
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 Open License Management, select “Single-User License” tab, and fill in the License ID 
Code. 

 

Figure 3-7 Set License ID Code 

 Click “Add LIC” button. 

 

Figure 3-8 Add License ID Code 
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 Finally, the license is active and successful message is shown. 

 

Figure 3-9 License is Active 

 

 Install Nu-Link KEIL/IAR driver: 

To use Nu-Link ICE with M2354, please install the Nu-Link driver by double clicking the installer 
file. 

 

Figure 3-10 Nu-Link KEIL/IAR Driver Installer 
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 Install OpenOCD: 

GNU Nuvoton Eclipse installer includes the installation of Eclipse and OpenOCD. To use Nu-Link 
ICE with M2354, please install default components by double clicking the installer file.  

 

Figure 3-11 GNU Nuvoton Eclipse Installer 

 

 

Figure 3-12 Default Components 
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 Install NuMicro ICP Programming Tool: 

To use tool functions, please install the ICP Programming Tool by double clicking the installer 
file. 

 

Figure 3-13 NuMicro ICP Programming Tool Installer 

 

 Install M2354 KEIL Software Pack: 

In KEIL MDK, It is necessary to update Nuvoton KEIL Software Pack to support M2354. In 
uVision5 IDE environment, click the “Pack Installer” icon to open the pack installer.  

 

Figure 3-14 Pack Installer 
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Select “Devices” tab and click “Nuvoton -> M2354”, then “Nuvoton:NuMicro_DFP” will be shown 
on Packs. Please install latest version by click “Install” or “Update” button. 

 

 

To install software pack offline, user can open “Pack Installer”. 

Then, use “File -> Import…” to install Nuvoton KEIL software pack. 

 

Figure 3-15 M2354 Software Pack File 
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4 BLINKY SAMPLE CODE 

The Blinky sample code is a simple code to toggle LED on/off around the NuMaker-M2354 board. 

The project file is located at: 

bsp\SampleCode\NuMaker\Blinky\Keil\Blinky.uvprojx (For KEIL MDK) 

or 

bsp\SampleCode\NuMaker\Blinky\IAR\Blinky.eww (For IAR EWARM) 

or 

bsp\SampleCode\NuMaker\Blinky\GCC (For GNU Nuvoton Eclipse) 

 

 Connect the Nu-Link2 ICE on the NuMaker-M2354 board to PC with USB 

 

Figure 4-1 NuMaker-M2354 Board 

 

The Nu-Link2 ICE has a Virtual COM port function for debug messages. After connecting Nu-
Link2, user can find VCOM on hardware manager in Windows PC. 

 

Note1: 

 Nu-Link driver (KEIL or IAR) should be installed first before using the VCOM. 

Note2: 

 The ICESW2 needs to be set as below to enable VCOM function of Nu-Link2 ICE. 

Nu-Link2 ICE 

ICESW2 
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Figure 4-2 

 

 

Figure 4-3 Nuvoton Virtual COM Port 

 

A terminal tool can be used to open the Virtual COM port to monitor the M2354 debug message. 

 

 Reset to factory default state: 

User can use full chip erase function to reset the NuMaker-M2354 board to factory default state 
by ICP Programming Tool by the following steps: 

1. Double click the “NuMicro ICP Programming Tool.exe” to run ICP Programming Tool. 

2. Select target chip as “M2354 Series” and then click “Continue >>”. 

3. Click “Connect” to wait for M2354 being connected with Nu-Link. 
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4. After chip is connected to ICP Programming Tool, click “Tool -> Erase Whole Target Chip”, 
and then click “OK” twice. 

5. When full chip erase has done, tool will read flash data again. Click “Disconnect” to let 
M2354 disconnect from ICP Programming Tool. 

 

Figure 4-4 Do Full Chip Erase Step 1 
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Figure 4-5 Do Full Chip Erase Step 2 

 

 

Figure 4-6.1 Do Full Chip Erase Step 3 

 

 

Figure 4-7.2 Do Full Chip Erase Step 3 
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Figure 4-8 Do Full Chip Erase Step 4 

 

 

Figure 4-9.1 Do Full Chip Erase Step 5 

 

 

Figure 4-10.2 Do Full Chip Erase Step 5 
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 Open the sample code: 

User can open the sample code with KEIL uVision5 by double clicking the “Blinky.uvprojx” file. 

 

Figure 4-11 Blinky KEIL Project File 

 

Figure 4-12 Blinky Sample Code KEIL Project Screenshot 
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If IAR EWARM is used, user can open the project by double clicking the “Blinky.eww” file. 

 

Figure 4-13 Blinky IAR Project File 

 

 

Figure 4-14 Blinky Sample Code IAR Project Screenshot 

 

If GNU Nuvoton Eclipse is used, user can open the project by the following steps: 

1. Double click the “eclipse.exe” to run GNU Nuvoton Eclipse. 

2. “Browse…” a workspace directory and then click “OK”. 

3. Click “File -> Import…”, then select “General -> Existing Project into Workspace” and 
click “Next”. 

4. “Browse…” the Blinky GCC project directory and click “Finish”. 
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Figure 4-15 Open Blinky GCC Project Step 1 

 

 

Figure 4-16 Open Blinky GCC Project Step 2 
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Figure 4-17.1 Open Blinky GCC Project Step 3 

 

Figure 4-18.2 Open Blinky GCC Project Step 3 
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Figure 4-19 Open Blinky GCC Project Step 4 

 

Figure 4-20 Blinky Sample Code GCC Project Screenshot 
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 Build the sample code: 

User can click the “Rebuild” icon to build the sample code in KEIL MDK. 

 

Figure 4-21 Rebuild with KEIL MDK 

 

Or click “Project -> Rebuild All” in IAR EWARM. 

 

Figure 4-22 Rebuild with IAR EWARM 

 

  



M2354 

 

Sep. 22, 2020 Page 23 of 28 Rev. 3.01 

N
U

M
A

K
E

R
-P

F
M

-M
2
3

5
4
 B

O
A

R
D

 Q
U

IC
K

 S
T

A
R

T
 G

U
ID

E
 

Or click “Project -> Build Project” in GNU Nuvoton Eclipse. 

 

Figure 4-23 Rebuild with GNU Nuvoton Eclipse 

 

 Download firmware to M2354: 

User can click the “Download” icon to download the code to M2354 in KEIL MDK. 

 

Figure 4-24 Firmware Download with KEIL 
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Or click “Project -> Download -> Download active application” to download the code to 
M2354 in IAR EWARM. 

 

Figure 4-25 Firmware Download with IAR 
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Or click “Run -> Debug Configurations…” to open the debug configuration dialog in GNU 
Nuvoton Eclipse. 

 

 

Figure 4-26.1 Firmware Download with GCC 

 

Double click “GDB Nuvoton Nu-Link Debugging” to generate Nuvoton Nu-Link debug 
configuration “Blinky Release”, then click “Debug” to download the code to M2354. 

 

Figure 4-27.2 Firmware Download with GCC 
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 Press reset on the board to execute the code 

After downloading the code, user can press reset to execute the firmware. The IO_LED on the 
board will blink and a sample code message will be shown on the debug port. 

 

Figure 4-28 Blinky Sample Code Screenshot 

 

 NuMaker-M2354 board can be set as ICP or Mass-Storage by setting MSG of ISW1. If MSG is 
set to off, the NuMaker-M2354 is set as ICP that user can connect the Nu-Link ICE to PC, 
download code, and debug.  Otherwise, if MSG is set to on, the NuMaker-M2354 is set as Mass-
Storage. 
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5 REVISION HISTORY 

 

Date  Revision Description 

2020.09.22 3.01 1. Initially issued. 
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Important Notice 

Nuvoton Products are neither intended nor warranted for usage in systems or equipment, any 
malfunction or failure of which may cause loss of human life, bodily injury or severe property 
damage. Such applications are deemed, “Insecure Usage”.  

Insecure usage includes, but is not limited to: equipment for surgical implementation, atomic 
energy control instruments, airplane or spaceship instruments, the control or operation of 
dynamic, brake or safety systems designed for vehicular use, traffic signal instruments, all 
types of safety devices, and other applications intended to support or sustain life.   

All Insecure Usage shall be made at customer’s risk, and in the event that third parties lay 
claims to Nuvoton as a result of customer’s Insecure Usage, customer shall indemnify the 
damages and liabilities thus incurred by Nuvoton. 
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